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BD24-3 This class will reveal the power of the Autodesk Revit Schedule tools. Learn how to schedule rooms, areas, furniture, 
walls, doors, windows, curtain wall panels, planting, topography, electrical fixtures, and virtually anything. We will cover 
all the tips and tricks you will need to get the schedule you need—from custom fields, shared parameters, and grouping 
to schedule keys, formulas, and exporting. It’s all here. 

Who Should Attend 
Autodesk Revit users of all skill levels 
 
Topics Covered 
-  Scheduling dialog boxes 
-  Basic setup and formatting 
-  Multicategory schedules and shared parameters 
-  Advanced schedule techniques 
-  Exporting schedules 

 

 

 

 

 

 

 

About the Speaker: 
Jim Balding is a licensed architect with 17-plus years of experience integrating technology into the architectural field.  
He is currently employed with Wimberly Allison Tong & Goo (WATG) in Newport Beach. He has been a member of the 
Autodesk® Revit® Client Advisory Board since its inaugural meeting and is currently serving as the Revit Product 
Chair for AUGI®.  He has developed a successful Autodesk Revit implementation strategy and has spent the past two 
years bringing the seven offices of WATG up to speed in its use. 
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Schedules 
It has been said that one of the most tedious and unrewarding tasks in an AEC firm is compiling, counting and 
organizing schedules.  Whether it be doors, windows, vents, parking stalls, sheets or anything else, the time 
spent is much better spent elsewhere.  Does this sound familiar, “John, today you are going to count, 
categorize and organize all of the windows on this project”.  Ironically, computers are excellent at these tasks.  
Because Revit is a central database of building information scheduling is quick, accurate and simple.  The fact 
that you can create an accurate custom schedule in a matter of minutes means you can spend more time 
designing and less worrying about the count and sizes of your windows.  For that matter you can create several 
custom schedules and provide more, specific information for better communication, resulting in less confusion 
in the field.  Virtually every object in Revit can be scheduled. 

Beginner 

Creating a Schedule 
There are two ways to begin a schedule.  You can access the from the View menu New|Schedule/Quantities or 
from the View Design Bar “Schedule/Quantities”.  Either way will get you to the New Schedule dialog box. 

The New Schedule Dialog box 
Category – This is the area where you tell Revit what 
type of schedule you would like to create.  Once 
selected Revit will populate the available fields for that 
category for you. 

Name – This is the name of your schedule and will 
appear in the top line of the schedule. 

Schedule Building Components/Schedule Keys 
– This is where you will be telling Revit what you 
indend on using this schedule for.  (See Schedule Keys 
below. 

Phase – This is where you set up the phase of 
consturction.  For use in multi-phased projects, this can 

assist in filtering a schedule as well. 
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The Schedule Properties Dialog 
The power of Revit’s schedules is controlled by the Schedule Properties dialog box with its five tabs.  Because 
the all schedules are controlled by these tabs, to create meaningful schedules, it is imperative that you 
understand each of these tabs and their functions. 

The Fields Tab 
Available Fields – This is where you choose which 
fields (parameters) will be displayed in the schedule. 

Scheduled fields – This is the list of fields that will be 
displayed in the schedule.  The order of fields is 
representative of how they will be displayed in the 
schedule, top to bottom = left to right on the schedule. 

Add Button – Use this button to add fields from the 
Available fields list to the Scheduled fields list.  NOTE: 
you can use Windows controls (ctrl + click or shift + 
click) to choose multiple fields. 

Remove Button – Removes fields from the 
Scheduled fields list. 

Add Parameter – Use this button to add additional parameters to this schedule.  It might be advisable to use 
the Shared Parameters function for this purpose to maintain consistancy across the project.  See Shared 
Parameters below. 

Calculated Value – The calculated Value button creates a field whose value is calculated from a formula 
based on other fields in the schedule. 

The Edit and Delete Buttons – These buttons allow you to edit/delete a user created field. 

Move Up/Move Down – This is where you control the order of the list, remember , top to bottom = left to 
right on the schedule.  

The Filter Tab  
The Filter tab allows you to restrict what elements are 
displayed in schedule 

Filter by – this field is where you chose the first 
criteria for filtering.  NOTE: All of the fields must be 
satisfied in order for an object to be displayed in the 
schedule. 
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The Sorting/Grouping Tab 
The Sorting/Grouping tab controls the order in which 
the information will be displayed – sorting and how it is 
organized – grouping. 

Sort by – Use this pulldown to identify which 
field/parameter you wish to sort by. 

Ascending and Descending Buttons – These are 
used to control the alpha-numeric order in which the 
parameters are displayed. 

Header and Footer - If you select the Header or 
Footer checkboxes this will indicate to Revit that you 
wish to Group by the selected field/parameter.  The 

footer checkbox also enables the Title, count and totals pulldown. 

Title, count and totals – When activated this allows you to define the information the footer will contain. 

Then by – If you would like to further group or sort your schedule use these pulldowns. 

Grand Totals – This checkbox will tell Revit that you would like to have the totals of the calculated fields at the 
bottom of the schedule. 

Itemize every instance – When checked Revit will display all instances of the object in the entire model that 
satisfies the constraints of the schedule.  When unchecked Revit will only display the types of the instances for 
this schedule.  A typical example of this would be the difference between a door and a window schedule.  A 
door schedule might show every instance of the doors as the parameters for each could vary slightly.  Where, 
in a window schedule you might uncheck this box and add the Count field to your schedule. 

The Formatting Tab 
The formatting tab controls the formatting of the 
individual fields/parameters (think columns). 

Heading – The heading field is where you would 
control the column title display.  In the example shown 
Thickness is abbreviated with Thk.  Thk will be 
displayed in the schedule. 

Heading orientation – This field controls the rotation 
of the column header.  The options are horizontal or 
vertical. 

Alignment – This field controls the alignment of the 
fields displayed, left, right or center justified. 

Field formatting – This button allows you to overwrite the project settings for numerical data.  An example 
might be that you change the area settings to round to the nearest whole square foot as opposed to two 
decimal places as the project parameters might dictate. 
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Calculate totals – This checkbox is used in numerical fields where you want Revit to calculate the sum of the 
data in that field 

Hidden field – This checkbox is used to hide a given field in a schedule.  It is most commonly used when that 
field is used as the grouping mechanism.  

The Appearance Tab 
This tab controls the appearance of the fonts used in 
the schedule.  I have outlined these controls below, 
however the best way to learn might be just to 
experiment with the settings on your own. 

Grid lines – This controls the line style that will be 
used for the grid lines.  NOTE: These lines will be used 
for all grids unless overwritten by the line styles below. 

Header Text – This line controls the font, size and 
type (bold/Italic) used in the headers  

Body Text - This line controls the font, size and type 
(bold/Italic) used in the body text. 

Line styles Outline, Title and Column headers – See examples below.  The “SHOW ME” Linestyle is 
OW” as a light grey line. displayed as a wide dark line with the “DON’T SH
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Column Grouping 
As shown in the examples above (No. and Room) can be grouped together under one heading (Location).  This 
is accomplished by highlighting the header cells (this will activate the group button in the tool bar) and pressing 
the Group button.  To ungroup, highlight the header cells and press the Ungroup button. 

The Printed Output 
Once a schedule has been created often will want to output it or place it on a sheet for printing.  To place a 
schedule on a sheet, use the same technique you would use to place any other view on a sheet, i.e. drag and 
drop it from the project browser.  Once on the sheet you may need to manipulate the location, height or the 
column widths.  To move the schedule simply drag it around the sheet until it is in the desired location.  If the 
schedule is too long for the height of the sheet use the break symbol (the “Z” at the midpoint to the right of all 

parate schedules.  If the column widths are too narrow or too wide use the 
ngles at the top of each vertical grid line). 

In

columns) to split it into two se
column grip to adjust (the tria

termediate 
Schedule Keys – As noted above another option when creating schedules.  The function of a schedule key is 

repetitive information.  For instance, a building might have 50 rooms that all 
, 

to minimize the manual input of 
have the same floor, base, wall and ceiling finishes.  When a schedule key is applied to those rooms the floor
base, wall and ceiling finishes are automatically filled out.  NOTE: In addition to assisting in the filling out of 
information, changes are also managed through the use of schedule keys.  For example, when the floor finish
changes, simply change the finish in the schedule key and all rooms with that key are automatically updated.  
(help section: schedules, key) 
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Multi-Category Schedules – On occasion you will need to schedule items from different categories.  Re
provides this functionality in the form of its Multi-Category scheduling fea

vit 
ture.  There are a few key concepts to 

understand before using multi-category schedules.  Multi-category schedules consider ALL components with in 
n the desired field information.  Of course a schedule on all of the components in a model is 

of little use.  When you set up a multi-category schedule you will make use of the filter tab.  This tab allows you 

ht 
, 

particular shee visions are added to a sheet the revision schedule will adjust 
automatically.  To create a revision schedule, open the titleblock select Vew|New|Revision Schedule.  Set up the 

the model and retur

to filter out all of the components that do not contain the filter parameter(s), so that you schedule onyx the 
components that do.  A typical example of a Multi-Category Schedule might be an electrical schedule that mig
include mechanical equipment, furniture systems and lighting fixtures (help section: schedules, multi-category 
creating) 

Revisions Schedules – Revision schedules automatically fill in from the revision clouds within views on any 
t.  As views containing re

schedule like any other schedule.  It should be noted that the revision tag has the ability to read the revision 
number or a revision mark.  This adds flexibility when placing your tags. (help section: revision schedules) 

Note blocks – Note blocks are schedules that can list all instances of annotations that are members of the 
Generic Annotation category only.  (Straight from the help section: note blocks)  Creating a note block is similar 
to creating any other schedule, View|New|Note Block.  You will need to have the symbol that you wish to 
schedule load prior to creating a schedule for it.  It should be noted that note block schedules do not act the 
same as the revision schedules in that they will list all instances of the objects whether they are included on any 
iving sheg et or not. 

o ways, 

e 
bar 

select Legend Component.  Once selected, you will have three fields in the options bar; select the family name 

Legends – Lengend views, new to 7.0, are views in which you can define all of the symbols in your project.  
Similar to note blocks, legends can be added to multiple sheets.  Creating a legend can be done in tw
from the View menu New|Legend or from the View tab on the design bar select Legend.  Once created, you 
have view the property controls you might expect.  Adding symbols, called “Legend Components”, can also b
done two ways, from the Drafting menu select Legend Component or from the Drafting tab on the design 

and type, the representational view and the host length (if applicable) 

 

Some of the legend t

x

ypes you might use are:  Annotative – Levels, Section Heads, etc., Line Styles, Materials – 
Filled Region (Hatch Patterns), Symbolic – Electrical fixtures, and Model Elements – Walls, Doors, Windows 

Advanced 
Calculated Values and Formulas in Schedules – These allow the user to create relationships between 
data generated by the schedule.  For example a user may wish to see the % of the total area of each space. 
This is done within the schedules view properties>Fields Tab>Calculated Value tab>  

Exporting Schedules – Revit has the capability of exporting schedules via ODBC for use in programs such as 
Microsoft Access.  The beauty of ODBC is that you can export to a database multiple times from the same 
project as the project develops.  The export will update the table data when it is e ported.  The Autodesk Revit 
online help has step by step procedures for this process.   

You can also export schedules as text delimitated data that can be read by Microsoft excel. 
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Room/Area reports – Revit allows you to export any floor plan with room tags to an html format room area 
report.  File>Export>Room/Area report.  The report creates a detailed list of the rooms in your project and the 

ML Schema” is designed 
to be a solid solution for architects, building designers, CAD developers, and product manufacturers who want 

e 

Prior to exporting your Revit model to gbXML the following will be required: 

1. All walls, doors and windows modeled 

Beyon nd lookup tables.  Some firms and contractors have created 
templates with corresponding spreadsheets and lookup tables to establish cost estimating. 

Q&A

areas associated with each room.  Since it is an html file it is very easy for clients to access. 

gbXML – gbXML is a new feature added to Revit in release 7.0.  “The Green Building X

to incorporate green building principles in their designs, tools, and products. The objective of this schema is to 
facilitate interoperability between the various building design and facilities management software tools in us
today as well as those that will be available in the future  

2. Room tags placed in all rooms 

3. Floors and ceiling placed in all rooms 

4. Input the projects address, including a zip code under Settings|Project Information dialog box within 
your Revit project. 

5. Save your file as a different name prior to running the export to gbXML. 

6. Click File|Export|gbXML 

Run a Google search on “gbXML Revit” to get more information on gbXML 

d Exporting – Cost estimating with Excel a
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