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BD34-1L Learn the basics of the Autodesk Architectural Desktop Project Browser and the Project Navigator. We will start by 
setting up levels based on project content and taking advantage of these new capabilities to manage building 
information and the building model. We’ll also create views and sheets using this powerful new tool. This class is 
designed for users who are proficient with building model creation in Architectural Desktop 2004 or newer releases but 
have little or no experience with the Project Browser/Project Navigator interface in Architectural Desktop. 
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Smooth Sailing with the Project Navigator 

Introduction 
The project for this lab will be a five-story 
apartment building. We will divide it into 
two divisions: “East Wing” and “West W
Using Project Navigator, we will be able to 
assemble views

ing”. 

 of the model based on 
levels and divisions for floor plans, 
elevations, sections and 3D views. 

We will start out by creating the project and 
setting up the model structure. Then we will 
assemble the various constructs and 
elements that make up the model 
geometry. Following that we will generate various view drawings, containing plans, sections and 
elevations, as well as detail views. Finally, we will place these on sheets and review the plotting 
and publishing features of the Sheet Set Manager. 

Setting up the Project 
We will use Project Browser to set up our project. In Project 
Browser, you create projects and manage all data about the 
project that does not pertain to the geometric structure of the 
project. 

• From the pulldowns, select File->Project Browser… 

• In Project Browser, use the navigation window on the left 
to navigate to the directory C:\Datafiles\BD31-4L 
(double click on the folder to make it the current folder) 

• Create the new project by picking the “New Project” 
button in the lower left corner of the dialog box. (See the 
image to the right). 

• Enter the Project Number as BD31-4L and the Project 
Name as Apartments. If you like, you can fill in a 
description, although that is not necessary. When you are 
finished, your project properties dialog  box should look 
like the one below (some of the pathing may be different, 
but the file names and other data should be the same). 

• Exit Project Browser after you have finished reviewing the data. 
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Establishing Levels and Divisions 
After creating your new project, Project Navigator should be available on your screen. If not, use 

 

 up the Levels

the pull-down menus and select Window->Project Navigator Palette. In the Project Navigator,
select the “Project” tab. This is where you begin to describe the project structure in a general 
sense. 

Setting  

vels” button in the “Project” tab of 

• 

tion: 0” 
: 10’-0” 

evel) 

• Making hecked 

 

etting up the Divisions

• Select the “Edit Le
the Project Navigator (see the image to the right). 

Edit the existing level as follows: 

Name: G 
Floor Eleva
Floor to Floor Height
ID: G 

ption: Garage (street lDescri

 sure that “Auto-Adjust Elevation” is c
on and using the “Add Level” button, add the rest of 
the levels so that your settings look like the figure 
below and select “OK”. 

 

 

 

 

 

 

 

 

 

 

 

S  

ons” button in the “Project” tab of 

• 

ing 

• Select the “Edit Divisi
the Project Navigator (see the image to the right). 

Edit the existing division as follows: 

Name: East Wing 
ID: E 

ption: East WDescri
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• Using the “Add Divisions” button add 
the “West Wing” division as shown in 
the image to the right and select “OK”. 

 

 

 

 

 

Adding Constructs and Elements 
We will begin by creating elements that will later be used in our constructs. Elements are 
components of the building model that can re-occur multiple times in the model. As such, they 
don’t have any information attached to them about “where they live” in the model. Constructs, on 
the other hand, should only occur once in a model, and will have properties that define exactly 
what parts of the model they occupy. When working with elements and constructs, it is very 
important to have a clear understanding of the ramifications of XREF’s that are attached versus 
XREF’s that are overlaid.  

Once all of the “typical” elements are created, we will assemble a few typical constructs before 
moving on to a more complete version of our project to begin working with views. 

Creating the 2D Footprint Element 

In the Project Navigator, go to the “Constructs” tab. 

• Select the “Elements” folder, right-click and select 
New->Category. 

• Name the new category “2D Reference Geometry” 

• With the “2D Reference Geometry” category selected, 
right-click and select New->Element. 

• In the “Add Element” dialog box that appears, name 
the new element “2D Building Footprint” and select 
“OK”. The Project Navigator display should look like 
the figure to the right. 

• Double click the “2D Building Footprint” element in the Project Navigator to open it. (This is 
the way to open files when using project management – do 
not use the “Open” command). 

• Use the “Insert” command to insert the file “Building 
Footprint” from the “C:\Datafiles\BD31-4L\Source 
Drawings\Elements” folder for this lab at the coordinates 
0,0,0. This will save you the trouble of drawing the 
geometry. Make sure you insert the block exploded, or 
explode it after you insert it. Your drawing should contain the 
geometry shown to the right. 

• Save and close the element. 

It is a good idea to generate a simple 2D sketch such as this, especially if you are using divisions 
to make sure that you are drawing your building components in the correct location for the parts 
of the model they occupy. 
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Building the “Typical” Elements 

• Using the techniques in the last steps, create a new category under “Elements” called 
“Typical Floors”. 

• Create a new element called “Typical Partitions – East Wing” and open it. 

• From the Project Navigator, right-click on the “2D Building Footprint” element and select 
“XREF Overlay”. It should appear in your drawing. You can also drag and drop elements 
into drawings, but when done in that manner, they will come in as attachments. Since this 
element does not need to follow the model geometry into any views, “Overlay” is more 
appropriate. 

• Insert the drawing “Typical Partitions – East Wing” from the “C:\Datafiles\BD31-
4L\Source Drawings\Elements” folder in the same manner as the 2D building footprint 
from the previous steps. It should appear on top of the 2D geometry on the section marked 
“East Wing”. Again, this simulates actually drawing the geometry. 

• Save the element and close it. 

• Using the same steps as those outlined above, c
the following elements and insert the associa
source drawings, making sure each one comes in at
coordinates 0,0,0 and exploded: 

reate 
ted 

 

Typical Partitions – West Wing 
Typical Core 
Typical Shell – East Wing 
Typical Shell – West Wing 

Once you have saved and closed all elements, your project 
navigator display should look like the figure to the right. 

Creating the 2nd Floor Constructs 

• Using the techniques from the previous steps, create 
three new categories under the “Constructs” folder: 
“Core”, “Partitions” and “Shell”. 

• In the “Shell” category, create a new construct. 
Since constructs must exist in an explicit part of the 
model, you will need to provide more information. 
Name the construct “Shell02E”, provide a description 
of “2nd floor shell, east wing”. In the matrix for 
“Assignments”, select the box under the “East Wing” 
division for the 2nd Floor. The “Add Constructs” 
dialog should look like the image to the right. 

• Select “OK” to finish creating the construct. 

• Double click the new “Shell02E” construct to open it. 

• From the Project Navigator, locate the “Typical Shell 
– East Wing” element that you created earlier. Select 
it and drag it into the drawing area. This will attach 
the element as an XREF (using the “Attach” option so that it will “follow” the current 
construct into any views it winds up in). 

• Save and exit the “Shell02E” construct. 
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• Create the following 2nd floor constructs in the appropriate categories: 

Construct 
Name 

Category Description Level Division Remarks 

Shell02W Shell 2nd Floor shell, west 
wing 

2 West Wing Drag and drop 
(attach) element 
“Typical Shell – West 
Wing”. 

Partitions02E Partitions 2nd floor partitions, 
east wing 

2 East Wing Drag and drop 
(attach) element 
“Typical Partitions – 
East Wing”. 

Partitions02W Partitions 2nd floor partitions, 
west wing 

2 West Wing Drag and drop 
(attach) element 
“Typical Partitions – 
West Wing”. 

 

• Create the 2nd floor core construct. This will 
be a “spanning construct” because it will 
actually occupy portions of both the East and 
West divisions. Create the construct in the 
“Core” category and provide a name of 
“Core02” with an appropriate description. In 
the “Assignments” section of the dialog box, 
select both the “East Wing” and “West Wing” 
divisions for the 2nd floor. You will be notified 
at the bottom of the dialog that this is now a 
spanning construct. The dialog should look 
like the image to the right. 

• Open the 2nd floor core construct and drag the 
“Typical Core” element into it, then save and 
close the file. 

• Create the stair tower construct. This 
construct will span multiple levels as well as 
divisions. Create the construct in the “Core” 
category. Provide a name of “Lobby Stairs 1-
P” and an appropriate description. In the 
“Assignments” area, select the “East Wing” and “West Wing” divisions for the 1st, 2nd, 3rd 
and “Penthouse” levels, then select “OK”. 

• Open the stair tower construct and insert the source drawing “C:\Datafiles\BD31-
4L\Source Drawings\Constructs\Stair Tower”. Make sure you insert this drawing 
exploded.  

• Save and close the stair tower construct. 

• Create the entry curtainwalls construct will also span multiple levels and divisions. Since it 
starts on the first floor and goes through the penthouse level, it will have much the same 
properties as the stair tower construct. Create the construct in the  “Shell” category, 
provide a name of “Entry Curtainwalls” and select both the “East Wing” and “West Wing” 
divisions for all levels except for the garage level. 
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• Open the “Entry Curtainwalls” construct and insert the source drawing 
“C:\Datafiles\BD31-4L\Source Drawings\Constructs\Curtainwalls” into the file, 
exploded. 

• Save the construct and close it. 

Creating View Drawings 
Plan Views 

• Navigate to the “Views” tab. Select the “Views” category, right click and create a new 
category called “Plans”. 

• In the “Plans” category, right click and select the option to create a new “General” view. 
This will place you in the “New View” wizard. On the first screen, provide a name of “FP02” 
(and a description if you wish), then select “Next”. 

• In the next screen (“Context”), choose the “East Wing” and “West 
Wing” divisions for the 2nd floor only. This will specify that you 
only want those constructs that apply to those parts of the model 
included. Click “Next”. 

• In the next screen (“Content”), you verify the actual constructs to 
be included. You should note that all 2nd floor constructs are 
included, as well as any spanning constructs that exist at least in 
part in any of the divisions or levels you have specified for the 
view, as in the image to the right. 

• Select “Finish”, then double click the view in Project Navigator to 
open it. A complete floor plan of the 2nd floor should be created 
from external references of your 2nd floor constructs. You might 
want to generate a 3D view as well and note that the curtainwalls 
and stair tower constructs are placed at the correct relative 
elevation to the other 2nd floor constructs. 

• Save and exit the view. 

Elevations, Sections and Callouts 

• To facilitate things, open a version of the project that is at a 
later stage of completion. In Project Navigator, regardless of 
the tab that you are currently on, select the “Launch Project 
Browser” button at the bottom (refer to the image on the 
right). 

• In Project Browser, make the project “Apartments – 
Complete” current. Take a moment in Project Navigator to 
note that many more constructs have been added to complete the model and there have 
also been a few additional views created as well. 

• Open the “FP02” View, which is the same 2nd floor plan view that you created earlier. 

• From the “Document” Tool Palette group,  select the “Callouts”  tab. 

On th• e “Callouts” tab, select the “Exterior Elevation Mark A3” 
 tool (See the image to the right), which will allow you to create

four elevation views of the model at the same time. 
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• At the prompt to specify the elevation region, 
place a window around the entire floor plan, 
leaving some space around the edges. 

• In the “Place Callout” dialog that appears, 
match your settings with the image to the 
right. 

• Select the “New View Drawing” button. 

• In the next dialog box, specify a view name of 
“Exterior Elevations” and make sure you set 
the category to be “Views\Elevations”. 

• Select “Next” to page through the next two 
dialog boxes, noting that all model 
components are automatically selected. 

• When prompted to select the elevation 
insertion point and spacing, select a point a 
fair distance to the right of the flooplan and 
then select another point about 20 or 30 feet 
to the right of the first point. 

• Once all four elevations have been created (it will probably take a few minutes), expand 
the “Elevations” category in the “Views” tab. There should be a new view drawing named 
“Exterior Elevations”. Expand it by selecting the “+” sign. You should see four views; one 
for each elevation.  

• Select the view entitled “South Elevation” an
and place you in that view. This is where yo

• Close the “Exterior Elevations” drawing (you

• Save the view “FP02”, but do not close it. 

Creating Plot Sheets

d double click on it. The drawing should open 
u would edit the elevation and annotate it. 

 don’t need to save). 

gator. This is actually the Sheet Set Manager 
ated with the project management features of 

 
• Navigate to the “Sheets” tab of Project Navi

that comes with AutoCAD 2005, tightly integr
Architectural Desktop 2005. 

• Under the “Architectural” subset, select the 
“Plans” subset and right-click, selecting 
New->Sheet 

• In the new sheet dialog, enter a sheet 
number of “A-103” and a sheet name of 
“Typical Floor Plan” as in the image to the 
right. Select “OK”. 

• Double-click on your new sheet to open it. 

• Navigate to the “Views” tab and select the “FP02” view from the “Plans” category, 
expanding it out by selecting the “+” sign. Right click on the view “Typical Floor Plan” and 
select “Properties”. Take note of the settings for Display Configuration and scale and select 
“Cancel”. 

• Drag and drop the “Typical Floor Plan” view into your sheet.  

• Save the sheet. 
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operties”. Match your settings 

elevations views. 

Cre

the “Elevations” subset. 

eet name of “Exterior Elevations”. 

ng on it. 

e “Exterior Elevations” view drawing, then drag 
views will be placed on your 

d (they will probably not all fit on the sheet. 
se, let them run over the sheet border if necessary. 

rn it to the drawing editor. 

e

er the “Architectural” subset and create a new 
r “G-101” and title “Cover Sheet”. 

 drawing by double-

• In the sheet list dialog box, make sure the ta

y”. 

• Select the “Add” button on the right to 
he 

w 

ist. Your dialog should 

(Note the “Issue Date” field is a custom 

“OK” to place the sheet index. 

Set the properties for your elevation views.  

• Navigate to the “Views” tab and 
select the “North Elevation” view 
in the “Exterior Elevations” view 
drawing. Right click and select 
“Pr
with the image to the right. 

• Make the same settings to the remaining 

ate an elevation sheet. 

• Navigate to the “Sheets” tab and select 

• Right-click and select New->Sheet. 

• Provide a number of “A-201” and a sh

• Open the new sheet by double-clicki

• Navigate to the “Views” tab and select th
and drop it (the entire drawing) into your sheet. All four 
sheet. Locate each one as you are prompte
For purposes of this exerci

• Save the current sheet drawing. 

• Navigate back to the “Sheets” tab and select your “Typical Floor Plan” sheet. Double 
click on it to retu

• Type “REA” at the command line to regenerate all viewports, then ZOOM in to one of 
the elevation callouts. It should now indicate the correct detail and sheet number. 

Cr ate a cover sheet with a sheet index. 

• Right click on the “General” subset und
sheet with the numbe

• Open the cover sheet clicking on it. 

 

ble style is set to “Sheet List” and that the 
side of the dialog box) are “Sheet 

• Right-click on the “Apartments” header for the sheet set in the “Sheets” tab and select
“Insert Sheet List”. 

current data fields to use (shown on the right 
Number”, “Sheet Title” and “Drawn b

add a field to the table and change t
default “Sheet Number” field in the ne
entry to “Issue Date” by picking it from 
the drop down l
look similar to the image to the right. 

sheet field that is not normally present 
in the default sheet set data file).  

• Select 
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Onc p t, the sheet index will list the sheets in the order that they appear in the 
“Sh arranged and the sheet index updated by right-
clic e.  

Plotting

e laced on the shee
eets” tab of Project Navigator. They can be re
king on it. New fields can be added at any tim

 
 Architectural Desktop 2005 is b
 in AutoCAD 2000, however using 
nt. In this exercise, we will pu

Plotting in ased on the same concepts and basic tools that were 
introduced the Sheet Set Manager you can automate them to a 
large exte blish our sheets to a multi-sheet DWF, however using 
Page Setups you can automate batch plotting to virtually any plot device that you currently use. 

• Close out of all open drawings, saving when prompted. Make sure you are open in a blank, 
 

• g ish to DWF. Save the 
4L\Apartments.dwf”. 

• xplorer to 
navigate to the folder “C:\Datafiles\BD31-4L” and double click on the “Apartments.dwf” 

e  few moments browsing through the 

Summa

non-project-related file.

Ri ht-click on the “Architectural” subset, then select Publish->Publ
DWF file to the file “C:\Datafiles\BD31-

Once the DWF has been created (it may take a few minutes), use Windows E

fil . It should appear in the DWF Viewer. Spend a
pages of the plot set. 

ry 
xercises you: In these e

• evels 

• e
com

• m

• Created section and elevation views with linked callouts in the plan views. 

• Assembled your views on sheets and created a title sheet. 

• Plo

In this lab, ject Navigator. There are 
several additional scenarios and options that time does not allow coverage for in this session, 
however. Y
Navigator to become more comfortable with it’s features and capabilities. 

 

Created a new project and assigned l

Cr ated new elements and constructs and combined them together to build model 
ponents 

Co bined the various model elements into cohesive views. 

tted your drawing set to a multi-page DWF file. 

 you should have gotten a “feel” for the workflow in Pro

ou should spend time with the online tutorials and just “playing around” with Project 
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